Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Dead Island

Reply
 
Thread Tools Display Modes
Old 09-06-2011, 11:07 PM   #16
oldbrokenlink
 
Join Date: Apr 2011
Reputation: 359
Posts: 3,018
sadly no push to talk

you can pull the mic out or disable the mic in sound settings
oldbrokenlink is offline   Reply With Quote
Old 09-07-2011, 07:30 AM   #17
Darwin's T of E
 
Join Date: Sep 2011
Reputation: 0
Posts: 2
Voice chat... so far...

I, like many others, use Teamspeak 3 with friends when playing online games. This typically includes disabling any in-game voice system in lieu of Teamspeak. As anyone who has tracked down this thread would know, this does not seem to be an easy task with Dead Island. Here's what we've found:

- The Dead Island in-game voice chat system is linked to the Steam voice settings. (Almost, read below.)

- Dead Island settings default to a voice activated mic, much like that of an Xbox 360 setup.

- If your third party VoIP service is set to push to talk (PTT), using that service in-game with your mates causes the undesirable echo.

The goal for us was to find a way to disable the Steam VoIP system, thereby disabling Dead Islands voice chat. An additional headache is that Steam seems to call on the Windows 7 settings for the default microphone and communication device.

So far, one of us achieved this by setting up a second mic with an 'off' switch to a second audio input and then adjusting all Windows and Steam settings to use that input exclusively. By setting your third party VoIP of choice to use the desired mic/audio input you can enable the third party software, while disabling the in-game voice chat.

An important note, it seems that an active device (Which is completed by the addition of a second microphone in this case.) is required for this work-a-round. If that mic does not have a 'off' switch, you would still be transmitting in-game from this device. Two of us have had little luck by setting a "currently unavailable" device to default in the Windows 7 settings, as Dead Island seems to find the same device used for Teamspeak.

Hope this works for someone else, or they add a fix. W/e.
Darwin's T of E is offline   Reply With Quote
Old 09-07-2011, 07:34 AM   #18
luckyjim
 
Join Date: Dec 2009
Reputation: 17
Posts: 338
My friend and I solved this problem by plugging in an extra device into our soundcard and setting the input to a microphone or line in device (when the system prompts you what device you plugged in), but leaving it muted. Steam will pick up the DEFAULT input device.

Then it was a matter of choosing the ACTUAL device in Skype. It's been working ok so far. But now since the matchmaking server seems to be messed, we're trying Tunngle now as well. What a pain, but I do love the game when it works
luckyjim is offline   Reply With Quote
Old 09-08-2011, 03:41 PM   #19
NuclearKetchup
 
Join Date: Dec 2008
Reputation: 19
Posts: 272
I'm bumping this because it needs to be addressed.

This is another basic PC gaming feature that has been carelessly left out by the developers. Please fix this nonsense.
NuclearKetchup is offline   Reply With Quote
Old 09-08-2011, 03:43 PM   #20
Verwandlung
 
Join Date: May 2009
Reputation: 195
Posts: 1,398
Another valid complaint regarding this POS game.
Verwandlung is offline   Reply With Quote
Old 09-08-2011, 03:44 PM   #21
Cobalt2202
 
Join Date: Nov 2008
Reputation: 35
Posts: 538
Good thing is, there is a simple switch to turn off the mic.
Cobalt2202 is offline   Reply With Quote
Old 09-08-2011, 03:44 PM   #22
NuclearKetchup
 
Join Date: Dec 2008
Reputation: 19
Posts: 272
Quote:
Originally Posted by Cobalt2202 View Post
Good thing is, there is a simple switch to turn off the mic.
Yeah? Where is it?

Unless of course you mean MUTE the microphone so it can't be used by any third party voice program.

In that case that isn't a solution my friend. Echo is unbearable when trying to play with friends, not everyone has a headset or even desires to use one.

We need an option to disable the ingame voice so we can use vent/teamspeak, OR give us a push to talk button ingame.

Anyone who disagrees has a bad case of consolitis.
NuclearKetchup is offline   Reply With Quote
Old 09-08-2011, 03:46 PM   #23
Avs
 
Join Date: Apr 2007
Reputation: 20
Posts: 532
Here's the only workaround I've found.

Windows 7:
  1. Go to Recording Devices
  2. Find a different device that's not your primary mic such as Line In, or Realtek Digital Input.
  3. Set that other device as your default device (aka. set both default and default communications device to the "Line In" or alternative input.
  4. Make sure skype is set to still use your microphone or whatever actual mic device.
  5. No more ingame sound.
  6. I believe you can also disable or default the steam's microphone settings too since it uses the windows recording settings as its primary device.
Avs is offline   Reply With Quote
Old 09-08-2011, 03:47 PM   #24
BTSpaniel
 
Join Date: Sep 2011
Reputation: 0
Posts: 12
2 Things you can try

1) Steam > Settings > Voice > Receive and Microphone Volume to 0
2) go into option in dead island go to Game turn Speech Volume to 0
BTSpaniel is offline   Reply With Quote
Old 09-08-2011, 03:48 PM   #25
NuclearKetchup
 
Join Date: Dec 2008
Reputation: 19
Posts: 272
Quote:
Originally Posted by BTSpaniel View Post
2 Things you can try

1) Steam > Settings > Voice > Receive and Microphone Volume to 0
2) go into option in dead island go to Game turn Speech Volume to 0
Why would I want to lower the voices of the characters in the game?

Also the steam setting does nothing.
NuclearKetchup is offline   Reply With Quote
Old 09-08-2011, 03:50 PM   #26
Phreeflo
 
 
 
Join Date: Feb 2011
Reputation: 217
Posts: 1,613
Yeah this needs fixing.

Every console to PC game screws this up , how can they not learn.
Phreeflo is offline   Reply With Quote
Old 09-08-2011, 03:52 PM   #27
Verwandlung
 
Join Date: May 2009
Reputation: 195
Posts: 1,398
Quote:
Originally Posted by Phreeflo View Post
how can they not learn.
Because people keep believing the "we are creating a true pc version" BS and keep buying this (myself included )
Verwandlung is offline   Reply With Quote
Old 09-08-2011, 03:54 PM   #28
Matra
 
Guest
Posts: n/a
What if you just set a Push-to-Talk hotkey, different from your Ventrilo/Teamspeak one, in the Steam Voice settings? I just did that, but I have yet to try it out.
  Reply With Quote
Old 09-08-2011, 03:54 PM   #29
LioMajor
 
Join Date: Sep 2011
Reputation: 4
Posts: 18
They set us up again with an unfinished game.

WORKAROUNDS is a no-go if the game has a function itself for it.

Not to be able to configure it properly is insane.

ALWAYS ADD POSSEBILITIES TO DISABLE!

And LEARN!

The game can use the MIC > DISABLE/MUTE Switch
The game has Motion Blur > DISABLE Switch
The game has Bloom effect > DISABLE Switch

and so on...
LioMajor is offline   Reply With Quote
Old 09-08-2011, 03:55 PM   #30
Avs
 
Join Date: Apr 2007
Reputation: 20
Posts: 532
Quote:
Originally Posted by Avs View Post
Here's the only workaround I've found.

Windows 7:
  1. Go to Recording Devices
  2. Find a different device that's not your primary mic such as Line In, or Realtek Digital Input.
  3. Set that other device as your default device (aka. set both default and default communications device to the "Line In" or alternative input.
  4. Make sure skype is set to still use your microphone or whatever actual mic device.
  5. No more ingame sound.
  6. I believe you can also disable or default the steam's microphone settings too since it uses the windows recording settings as its primary device.
You know, this takes 2 seconds to setup, even if it is a workaround. It also fixes the in game voip issue. You might as well use it instead of ing.
Avs is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Dead Island


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 04:29 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.