Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Garry's Mod

Reply
 
Thread Tools Display Modes
Old 02-21-2011, 02:25 AM   #1
rpalp
 
Join Date: Feb 2008
Reputation: 0
Posts: 15
"hl2.exe has stopped working" crash on server join

I've looked all over Google and I can't find a real solution to this god awful problem. Every time I try to join a server I get this error. It finishes "sending client info" then crashes there. I'm using Windows 7 64-bit. I'd really appreciate any help with this problem.
rpalp is offline  
Reply With Quote
Old 02-21-2011, 02:52 AM   #2
The_Worst_One
 
Join Date: Jul 2009
Reputation: 0
Posts: 14
does this happen every time you join a server?
The_Worst_One is offline   Reply With Quote
Old 02-21-2011, 09:16 AM   #3
sporeguy
 
Join Date: Nov 2010
Reputation: 19
Posts: 1,101
toy around with what directx gmod is using
sporeguy is offline   Reply With Quote
Old 02-21-2011, 03:01 PM   #4
tschumann
 
Join Date: Mar 2009
Reputation: 148
Posts: 2,635
There are some suggestions here: https://support.steampowered.com/kb_...9402-MKEN-1517
tschumann is offline   Reply With Quote
Old 02-22-2011, 08:06 PM   #5
rpalp
 
Join Date: Feb 2008
Reputation: 0
Posts: 15
Okay so I just tried to connect to a server after like 3 tries of it crashing over and over again. I was literally in the server at the MOTD then it crashed. So if that helps anyone know what the problem could be could you please help me out.
rpalp is offline   Reply With Quote
Old 05-02-2012, 11:16 AM   #6
RonanZer0
 
 
 
Join Date: Jun 2011
Reputation: 20
Posts: 349
Period.

This thread is NOT going to be dead, i want to join my favorite server im not the kinda guy who 'deals' with that stuff > it worked before but not anymore same after sending client info 3 times in a row!!
RonanZer0 is offline   Reply With Quote
Old 05-02-2012, 11:24 AM   #7
Zekiran
 
 
 
Join Date: Jun 2008
Reputation: 4714
Posts: 21,990
When was the last time the game worked successfully?

Can you play single player?

Have you tried contacting the server admin? Have you made sure that the servers are actually up?

Did you try updating and/or rolling back your video drivers?

Also: Garry's Mod is often broken anyway, could it just be that the latest updates over the last few months have borked your game.
Zekiran is offline   Reply With Quote
Old 05-04-2012, 10:06 PM   #8
ElijahChondo43
 
 
 
Join Date: Jan 2012
Reputation: 672
Posts: 1,588
My brother had a similar issue.

Verify Integrity of Game Cache.

Check to see if there is an update for HALF LIFE 2. If so, download it and run it once. After Half-life 2 successfully plays(starts up, whatever) then try GMod.

There was a problem with hl2.exe for my brother's GMod and I updated his GMod and HL2 games, GMod works perfectly now.
ElijahChondo43 is offline   Reply With Quote
Old 05-04-2012, 10:42 PM   #9
Zekiran
 
 
 
Join Date: Jun 2008
Reputation: 4714
Posts: 21,990
Yeah that's something up in the sticky thread of mine, I hope at least (I haven't read the first couple posts in a while lol), that it's advised to open and run each Source game before you try using Gmod.
Zekiran is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > D - G > Garry's Mod


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 04:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.