Go Back   Steam Users' Forums > Steam Game Discussions > M - P > PAYDAY The Heist

Reply
 
Thread Tools Display Modes
Old 01-05-2012, 01:21 PM   #1
overkill_bo
 
OVERKILL Software
Join Date: Sep 2011
Reputation: 448
Posts: 1,562
Mouse lag hot fix (you need to know what you do here)

Hi guys

As you know we have eliminated the mouse lag for a lot of your guys but for you who still have it, we still work on a few things.

IF you are a bit savy and want to try a fix before it is in the MENU (PATCH 6).


This can be done by disabling threaded renderer (on 8600 cards this wont affect it)

With the game NOT running:

1) Go to:

C:\Program Files (x86)\Steam\steamapps\common\payday the heist

( or equivalent )


2) right-click file context.xml

3) select "edit"

4) find the entry <threaded_renderer value="true"/> and replace with <threaded_renderer value="false"/>


5) Start game

Note: Using "Verify integrity of game cache" may reset the file to its original state.


Thanks

Bo
overkill_bo is offline  
Reply With Quote
Old 01-05-2012, 01:40 PM   #2
mystrdat
 
 
 
Join Date: Nov 2008
Reputation: 478
Posts: 3,720
Okay, yes, we're getting somewhere here. Controls delay completely eliminated.

http://www.youtube.com/watch?v=eNkIVRBTdYk
mystrdat is offline   Reply With Quote
Old 01-05-2012, 01:55 PM   #3
overkill_bo
 
OVERKILL Software
Join Date: Sep 2011
Reputation: 448
Posts: 1,562
Cool. Can you post your PC specs`?
overkill_bo is offline   Reply With Quote
Old 01-05-2012, 02:04 PM   #4
Marshipop
 
Banned
Join Date: Dec 2011
Reputation: 0
Posts: 13
Quote:
Originally Posted by overkill_bo View Post
Hi guys

As you know we have eliminated the mouse lag for a lot of your guys but for you who still have it, we still work on a few things.

IF you are a bit savy and want to try a fix before it is in the MENU (PATCH 6).


This can be done by disabling threaded renderer (on 8600 cards this wont affect it)

With the game NOT running:

1) Go to:

C:\Program Files (x86)\Steam\steamapps\common\payday the heist

( or equivalent )


2) right-click file context.xml

3) select "edit"

4) find the entry <threaded_renderer value="true"/> and replace with <threaded_renderer value="false"/>


5) Start game

Note: Using "Verify integrity of game cache" may reset the file to its original state.


Thanks

Bo
It works for me; it's too good to be true! *sniff sniff

Are there any adverse side effects to this?
Marshipop is offline   Reply With Quote
Old 01-05-2012, 02:29 PM   #5
mystrdat
 
 
 
Join Date: Nov 2008
Reputation: 478
Posts: 3,720
Quote:
Originally Posted by overkill_bo View Post
Cool. Can you post your PC specs`?
Sure, on a notebook currently.

Intel Core i7 2630QM (Sandy Bridge)
4,00 GB Dual-Channel DDR3 @ 665MHz (9-9-9-24)
AMD Radeon HD 6570M
Windows 7 Pro 64-bit

Might as well mention I got a noticable framerate boost with the new patch.

If I set multithreaded on the physics element to false in the context.xml, it feels like the game runs way smoother - it tends to get somehow jerky in crowded places even though I'm well above 60 fps.

Code:
<physics settings="settings/physics_settings" fps="59" physx_effects="hardware" multithreaded="false"/>

Last edited by mystrdat: 01-05-2012 at 02:51 PM.
mystrdat is offline   Reply With Quote
Old 01-05-2012, 02:32 PM   #6
overkill_bo
 
OVERKILL Software
Join Date: Sep 2011
Reputation: 448
Posts: 1,562
Quote:
Originally Posted by Marshipop View Post
It works for me; it's too good to be true! *sniff sniff

Are there any adverse side effects to this?
No not really. We simply use a single thread render set up for the cards that should use that.
overkill_bo is offline   Reply With Quote
Old 01-07-2012, 10:28 PM   #7
nimbusland
 
 
 
Join Date: Dec 2009
Reputation: 281
Posts: 744
THIS WORKED FOR ME!!

Before this fix, i had to play the game in a low resolution, that was the only way to play without mouse issues. Now i can play 1920x1080 with no mouse lag!!

THANKS A LOT!
nimbusland is offline   Reply With Quote
Old 02-15-2012, 07:32 AM   #8
naruto-hokager
 
Join Date: Dec 2011
Reputation: 0
Posts: 11
When I applied your solution, I noticed a good mouse improvement
But he seems to have a little...

Here my system specs :

Windows 7 32 bits
Pentium 4 2.8 GHZ
1.5 go ram
Nvidia geforce 7300 GS 768 mo

Sorry bad english...
Good luck OVERKILL !

(Can you improve performance a bit ? The Patch 5 increase my FPS to 20, maybe option to disable shadows ?)
naruto-hokager is offline   Reply With Quote
Old 02-15-2012, 09:44 AM   #9
ap0k41yp5
 
 
 
Join Date: Jul 2010
Reputation: 11
Posts: 88
Quote:
Originally Posted by naruto-hokager View Post
(Can you improve performance a bit ? The Patch 5 increase my FPS to 20, maybe option to disable shadows ?)
Here is how to disable shadows :

1/ Go in C:\Users\xxxxxxxxxx\appdata\local\PAYDAY
where xxxxxxxxx is your windows username, and the appdata folder is a hidden folder.

2/ open renderer_settings.xml with notepad or notepad++ or any text editor

3/ add this line under between the <render_settings> and </render_settings> lines :
<variable name="shadow_quality" value="disabled"/>

If there is no <render_settings> lines, just add :

<render_settings>
<variable name="shadow_quality" value="disabled"/>
</render_settings>

just before </render_config>

Improves a lot the fps for me
ap0k41yp5 is offline   Reply With Quote
Old 02-15-2012, 10:03 AM   #10
Captain Chirac
 
Join Date: May 2008
Reputation: 50
Posts: 767
I still get lag with V-sync on, using this tweak.
Not a big deal at all, just giving feedback. Mouse input is otherwise perfect with V-sync off.
Captain Chirac is offline   Reply With Quote
Old 02-15-2012, 10:24 AM   #11
MADDMONKEY
 
 
 
Join Date: Jun 2010
Reputation: 58
Posts: 484
This helps but the mouse lag isn't gone for me.

Bo, would it be possible to add a way to cap fps in the context.xml?
If we could do it with a menu option that would be great, but It might be to late for that.

If we could cap fps ourselves to a preferred value, we could get consistent mouse movement whatever our preferences are. The game seems to be capped at 130fps. It would be nice if we could cap fps in a range from say 50-130fps.

I'm not sure about others but my video card gets hot from running at 130fps constantly. I'd like to experiment with lower fps caps with and without Vsync.

Capping fps would help the people with inconsistent fps like 55 fps in one area and 100 fps in others. These people can cap fps at 50 and remain consistent by capping fps at 50 or 55.

Last edited by MADDMONKEY: 02-15-2012 at 11:04 AM.
MADDMONKEY is offline   Reply With Quote
Old 02-15-2012, 03:42 PM   #12
naruto-hokager
 
Join Date: Dec 2011
Reputation: 0
Posts: 11
It's really strange without shadows... O_o

But in the 2nd map is better

But i think I could play like her
Thank very much ap0k41yp5 !!!! =D

If you have other solution to Improve Performance, do not hesitate to post them on the forum

Good night! (Yep i'm french)

Tomorrow I will play to First World Bank without lag !

Last edited by naruto-hokager: 02-15-2012 at 03:53 PM.
naruto-hokager is offline   Reply With Quote
Old 02-15-2012, 04:46 PM   #13
ap0k41yp5
 
 
 
Join Date: Jul 2010
Reputation: 11
Posts: 88
Quote:
Originally Posted by naruto-hokager View Post
If you have other solution to Improve Performance, do not hesitate to post them on the forum
I have a really crappy pc that shouldn't even be able to handle this game, but with some tweaks I can play with no lags and crappy graphics (but I'm getting used to it ^^).

In the game's graphics settings, I turned everything on the lowest, except for animations, I let them high.
In context.xml I use the two tweaks found in this thread : threaded_renderer to false and physics mutithreaded value to false too.
In renderer_settings.xml, I use this code for the <render_settings> part :
Code:
<render_settings>
 <variable name="dynamic_lights" value="false"/>
 <variable name="effect_quality" value="low"/>
 <variable name="environment_detail" value="0"/>
 <variable name="max_anisotropy" value="1"/>
 <variable name="post_effect_quality" value="low"/>
 <variable name="shadow_map_size" value="0"/>
 <variable name="shadow_quality" value="disabled"/>
 <variable name="texture_quality_default" value="high"/>
</render_settings>
Then pick a resolution adapted to your needs in the d3d_device part, for instance since I have a widescreen monitor, the lowest setting for me is "720 480". Don't forget to choose an aspect ratio according to the resolution you picked, and to your comfort (for instance I use 1.5 aspect ratio, but you can go to 1.8, or even 2 if you prefer).

Here it is, hope it helped
(btw I'm french too )

Last edited by ap0k41yp5: 02-16-2012 at 12:33 AM.
ap0k41yp5 is offline   Reply With Quote
Old 02-16-2012, 01:53 AM   #14
naruto-hokager
 
Join Date: Dec 2011
Reputation: 0
Posts: 11
Its increase my FPS of around 5, thank again
I can show my real skill now, without lag !
But just one little problem, when I click on "start the heist" normally will have loading screen, but he disappeared...
I think it's because of his : <threaded_renderer value="false"/>

But I can not back "true" is that it's removed the mouse lag by OVERKILL...
I hope he will fix his soon... (And also put your render setting in the main menu options )

Anyway, I think I could play online now
Thank ap0k41yp5 !
(Ah bon, ta un bon anglais :P)
naruto-hokager is offline   Reply With Quote
Old 02-16-2012, 03:16 AM   #15
ap0k41yp5
 
 
 
Join Date: Jul 2010
Reputation: 11
Posts: 88
Yeah, the game freezes now when in a loading screen, that's a shame since they are really well done and useful, hope overkill can fix it in patch 6 so we can remove mouse lag without breaking the game

(ouip je suis français-anglais ^^ Hésite pas à m'ajouter sur steam si tu veux faire qualques parties, dur de trouver des français avec qui jouer :3)
ap0k41yp5 is offline   Reply With Quote
Reply

Go Back   Steam Users' Forums > Steam Game Discussions > M - P > PAYDAY The Heist


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



All times are GMT -7. The time now is 12:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Site Content Copyright Valve Corporation 1998-2012, All Rights Reserved.